Dashboard light.

  1. edwin Enthusiast

    Messages:
    94
    Location:
    Lichfield
    When I turn on the ignition the choke light comes on, and the water temperature light comes on. As the engine warms, and the choke is pushed in, the choke light goes off. However, the water temp light stays on.
    I have driven the car for about 15 minutes max trip length,( no MOT at mo) and also had the engine idling for 15 minutes, and the water temp light does not go out. Any ideas. Its an '88 R4 GTL
     
  2. malcolm

    malcolm & Clementine the Cat Staff Member

    Messages:
    4,038
    Location:
    Bedford UK
    Sounds like the wire to the sensor has shorted. It comes out of the bundle of wires going through the bulkhead and makes it's way to a sensor on the left rear of the cylinder head. Maybe it has touched the exhaust manifold.
     
    jjad likes this.
  3. edwin Enthusiast

    Messages:
    94
    Location:
    Lichfield
    Hi, and thanks for the advice. I will have a scrute of that wire. We have just had the head off for a gasket replacement, and it may be that it was not re fitted. Will look. Thanks.
     
  4. edwin Enthusiast

    Messages:
    94
    Location:
    Lichfield
    Hi Malcolm. You mention a sensor on the left rear of engine, which way are you looking at the engine please. Edwin
     
  5. malcolm

    malcolm & Clementine the Cat Staff Member

    Messages:
    4,038
    Location:
    Bedford UK
    This thing is the temperature sensor -
     
    • temp-sensor.jpg
  6. edwin Enthusiast

    Messages:
    94
    Location:
    Lichfield
    Thats great, no doubt about it . Thanks again
     
Advertisements
Clementine's Garage
Clementine's
Renault 4 Garage
Clementine the Cat
 
Image of flower
Yellow R4
 
Réparateur d'automobiles